new1234.jpg

Archive

Posts Tagged ‘Bug’

VMware: Kritieke kwetsbaarheid in VMware vCenter-server actief aangevallen

June 7th, 2021 No comments

Aanvallers maken actief misbruik van een kritieke kwetsbaarheid in VMware vCenter Server en VMware Cloud Foundation waardoor het mogelijk is om kwetsbare systemen op afstand over te nemen. Op 25 mei kwam VMware met beveiligingsupdates, maar er zijn nog altijd ongepatchte servers. Die zijn een aantrekkelijk doelwit voor aanvallers, aldus het Cybersecurity and Infrastructure Security Agency (CISA) van het Amerikaanse ministerie van Homeland Security.

De kwetsbaarheid, CVE-2021-21985, is op een schaal van 1 tot en met 10 wat betreft de impact met een 9,8 beoordeeld. VCenter is een oplossing voor het beheer van virtual machines en gevirtualiseerde servers en wordt standaard geleverd met de vSAN-plug-in. Deze plug-in controleert invoer van gebruikers onvoldoende, waardoor een aanvaller met toegang tot de vCenter-server op afstand willekeurige code kan uitvoeren. Het maakt niet uit of er van vSAN gebruik wordt gemaakt of niet.

Hoewel beveiligingsupdates om het probleem te verhelpen sinds 25 mei beschikbaar zijn maken aanvallers inmiddels actief misbruik van de kwetsbaarheid om systemen over te nemen, waarschuwt het CISA. Ook securitybedrijf Bad Packets meldt dat aanvallers op grote schaal naar kwetsbare servers zoeken. Een exploit om misbruik van het beveiligingslek te maken is inmiddels op internet te vinden. Organisaties wordt dan ook aangeraden om de patches te installeren en wanneer dat niet mogelijk is een workaround toe te passen.

sanderdaems

Sander Daems is founder and author of this blog and working as a Lead (Sr.) Consultant by UNICA ICT Solutions. Sander has over 15 years experience in IT, primary focus: virtualization and modern worksplace.

More Posts - Website

Follow Me:
TwitterLinkedIn

Categories: VMware Tags: , , , ,

[VMware] Could not start VMX: msg.vmk.status.VMK_NO_MEMORY

March 29th, 2015 4 comments

Last week I had some issues with starting virtual machines on vSphere 5.5 hosts (enough capacity available), when I try to start up the VM I receive message:

Could not start VMX: msg.vmk.status.VMK_NO_MEMORY”

An error was received from the ESX host while powering on VM [name]
Head globalCartel-1 already at its maximum size of 7869288. Cannot expand
Could not start VMX: msg.vmk.status.VMK_NO_MEMORY

image

 

Cause

This issue is caused by a memory leak in the driver which fills the SWAP memory of the ESXi host, making it unable to response to any requests at all. This issue occurs with ESXi hosts running on HP hardware with these versions of AMS:

  • hp-ams 500.9.6.0-12.434156
  • hp-ams-550.9.6.0-12.1198610
  • hp-ams 500.10.0.0-18.434156
  • hp-ams-550.10.0.0-18.1198610


Solution

This is a known issue affecting ESXi 5.x. To resolve this issue, upgrade to AMS version 10.0.1.

For ESXi 5.0 and 5.1, see:

For ESXi 5.5, see:

 

Note: In some cases, commands running on the ESXi host fails with cant’t fork.  In this case the virtual machines running on the ESXi host needs to be powered off and the ESXi host rebooted. To verify the installed versions of AMS, run this command:

esxcli software vib list | grep ams

To remove the package on all hosts running on these AMS versions:

  1. Log in to the host using SSH. For more information, see Using ESXi Shell in ESXi 5.x and 6.0 (2004746).
  2. Run this command to stop the HP service (does not persist on reboot):
    /etc/init.d/hp-ams.sh stop
  3. Run this command to remove the VIB:
    esxcli software vib remove -n hp-ams
  4. Reboot the host.
    More information:

VMware

sanderdaems

Sander Daems is founder and author of this blog and working as a Lead (Sr.) Consultant by UNICA ICT Solutions. Sander has over 15 years experience in IT, primary focus: virtualization and modern worksplace.

More Posts - Website

Follow Me:
TwitterLinkedIn

VMware: VUM and MS SQL 2008 Standard support

July 25th, 2010 No comments

Duncan Epping wrote July 22nd:

I received multiple questions around this so decided to ask around internally. I managed to get ahold of the VMware Update Manager (aka VUM) Product Manager and after exchanging a couple of emails this is the outcome:

VMware vSphere Compatibility Matrixes

Table 13 on page 14 of the above linked document states that VUM doesn’t support MS SQL 2008 Standard. This is however untrue and should be considered as a document bug. It is supported and the document will be modified soon to reflect these changes.

 Oke, it’s a document bug, you can install it safely! 🙂

sanderdaems

Sander Daems is founder and author of this blog and working as a Lead (Sr.) Consultant by UNICA ICT Solutions. Sander has over 15 years experience in IT, primary focus: virtualization and modern worksplace.

More Posts - Website

Follow Me:
TwitterLinkedIn

Categories: VMware Tags: , , ,