new1234.jpg

Archive

Posts Tagged ‘Single Sign-on’

VMware: There is a problem authentication into the legacy vCenter Server using credentials provided by the user

May 16th, 2015 1 comment

During upgrade VMware vCenter Server 5.5.0 (based on Windows 2012R2) to 6.0.0 I received a warning message:

Error: There is a problem authenticating into the legacy vCenter Server using the credentials provided by the user.

Resolution: Check if vCenter Server is up and running. Double check provided vCenter Server credentials

 
VMpros.nl

 
Some troubleshooting:

  • All VMware vCenter Server Services are started
  • No warnings/errors in Microsoft Event Logs during setup
  • I can logon at the vSphere webinterface with credentials administrator@vsphere.local
  • When configure wrong SSO password in setup the setup says "The vCenter Single Sign-On credentials are not valid. Check the username and password and try again"
  • I can ping domain controller VMpros.local
  • I canceled the setup and generated a support file, at the time I received the warning message this setup log was generated, so far, nothing special:

MSI (c) (40:88) [17:15:28:813]: Invoking remote custom action. DLL: C:\Users\ADMINI~1.VMP\AppData\Local\Temp\MSI7329.tmp, Entrypoint: LaunchUpgradeRunnerPreUpgradePhase
MSI (c) (40!C8) [08:23:44:055]: PROPERTY CHANGE: Modifying PreUpgradeComplete property. Its current value is ‘0’. Its new value: ‘1’.
MSI (c) (40:D0) [08:23:47:186]: PROPERTY CHANGE: Modifying SSO_PASSWORD property. Its current value is ‘**********’. Its new value: ‘**********’.
MSI (c) (40:D0) [08:23:47:267]: PROPERTY CHANGE: Modifying VC_5X_PASSWORD property. Its current value is ‘**********’. Its new value: ‘**********’.
MSI (c) (40:D0) [08:23:47:288]: PROPERTY CHANGE: Modifying PreUpgradeComplete property. Its current value is ‘1’. Its new value: ‘0’.
MSI (c) (40:D0) [08:23:47:305]: Doing action: VM_LaunchUpgradeRunnerPreUpgradePhaseAsync

 

Solution

Reboot the vCenter Server… I restarted the setup and the installation can continue.. weird!

sanderdaems

Sander Daems is founder and author of this blog and working as a Sr. Infrastructure Consultant by IT-Value. Sander has over 10 years experience in IT, primary focus: virtualization, storage and SBC

More Posts - Website

Follow Me:
TwitterLinkedIn

VMware: Service ´VMware Kdc Service’ (VMwareKdcService) failed to start

August 13th, 2014 No comments

Last week I upgraded VMware vCenter server from version 5.0 to 5.5 Update 1c, during installation of vCenter Single Sign-On 5.5 I received this warning message:

Service ‘VMware Kdc Service’ (VMwareKdcService) failed to start. Verify that you have sufficient privileges to start system services

 
image

 

The service account which I´m using for the upgrade is Domain Administrator, I tied to start the service manually but the service won’t start. The Windows Event log was clean, but in the vmkdcd.log file (located at: C:\ProgramData\VMware\CIS\logs\vmkdcd) I found this error logs:

20140812092452.000:t@0:TRACE: Vmkdcd: stop
20140812092458.000:t@0:TRACE: VmKdcSrvOpenServicePortTcp called…
20140812092458.000:t@0:TRACE: dwError=87 errno=17
20140812092458.000:t@0:TRACE: VmKdcSrvOpenServicePortTcp done.
20140812092458.000:t@0:TRACE: ERROR: vmkdc VmKdcInit failed (87)

20140812092458.000:t@0:TRACE: Vmkdcd: stop
20140812092503.000:t@0:TRACE: VmKdcSrvOpenServicePortTcp called…
20140812092503.000:t@0:TRACE: dwError=87 errno=17
20140812092503.000:t@0:TRACE: VmKdcSrvOpenServicePortTcp done.
20140812092503.000:t@0:TRACE: ERROR: vmkdc VmKdcInit failed (87)
20140812092503.000:t@0:TRACE: Vmkdcd: stop

 

Solution:

To resolve this issue, ensure port 88 is available for use by the VMware Kdc Service:

  1. Use netstat from an elevated command prompt on the Windows host system to confirm port 88 is not in use. For more information on using the netstat command, see Determining if a port is in use (1003971).
  2. If another application is using port 88, reconfigure or disable the application to open port 88 for use with the VMware Kdc Service.

In my case VMware Converter Standalone Server was running and configured at port 88, I removed the installation and restarted the Single Sign-On setup.

 
More information: VMware

sanderdaems

Sander Daems is founder and author of this blog and working as a Sr. Infrastructure Consultant by IT-Value. Sander has over 10 years experience in IT, primary focus: virtualization, storage and SBC

More Posts - Website

Follow Me:
TwitterLinkedIn