new1234.jpg

Archive

Posts Tagged ‘Support’

VMware: Perf Charts service experienced an internal error

December 16th, 2015 No comments

A few weeks ago a customer asked me to take a look at the following warning message in VMware vCenter when the Performance Tab in the vSphere client is being opened.

  

Perf Charts service experienced an internal error.

Message: Report application initialization is not completed successfully. Retry in 60 seconds

 
image


Troubleshooting time

Global checks:

  • The Windows Event logs are clean
  • VMware vSphere (web-) services are started with normal credentials
  • I was able to restart service accounts with domain based credentials (no locking)
  • Windows Firewall was enabled but no drops in the logging
  • No recent installed Windows Updates
  • No unplanned restarts or crashes
  • The installed certificate was not expired
  • The installed certificate was 2048 bit
  • No conflicting webserver ports at the vCenter server
    ..some more troubleshooting

I checked the wrapper.log and stas.log files located at the following location:

Path: C:\ProgramData\VMware\VMware VirtualCenter\Logs\

clip_image002

 

 

 

 

 

 

 

 

 

  

clip_image002[5]

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Hmm, he logging shows that there are problems with the installed vCenter SSL certificate:
 

Error constructing private key..

..Error decrypting password

After some troubleshooting I saw that every time I open the Performance tab a new webserver SSL private key decrypting error was written in the stats.log.

I already had checked the expire date of the installed SSL certificate, it was a normal 2048 bit wildcard certificate.. oh, eh, wildcard..?? Let’s see if it is supported:

“The use of wildcard certificates are not supported with vCenter Server and its related services. Each service must have its own unique certificate”

Nope, it is not! Maybe this is the root cause.

After checking the SSL requirements at the VMware KB  I found the SSL format which is needed to generate the certificate: OpenSSL Version 0.9.8 must be used. If you do not use this version, the SSL implementation fails. <– I couldn’t check this because there was no documentation of the SSL generation

 

Solution

The customer used a wildcard SSL certificate which is not supported

More information: VMware

sanderdaems

Sander Daems is founder and author of this blog and working as a Sr. Infrastructure Consultant by IT-Value. Sander has over 10 years experience in IT, primary focus: virtualization, storage and SBC

More Posts - Website

Follow Me:
TwitterLinkedIn

VMware: Install VMware vCenter Support Assistant 6.0.0 appliance

November 20th, 2015 No comments

Install and configure VMware vCenter Support

1. Download the VMware vCenter Support Assistant

2: Deploy the OVF > Accept license agreement > login to the appliance’s IP via web browser (login/password –  root/vmware)

3: From withing the web UI of the appliance, connect and push the installation of vCenter web client plugin > Enter SSO user name and password > done

 

image

 

 

 

 

 

 

 

Read more…

sanderdaems

Sander Daems is founder and author of this blog and working as a Sr. Infrastructure Consultant by IT-Value. Sander has over 10 years experience in IT, primary focus: virtualization, storage and SBC

More Posts - Website

Follow Me:
TwitterLinkedIn

VMware: How to rollback ESXi 5.1 to 5.0

October 3rd, 2012 7 comments

VMware vSphere ESXi 5.1 was released last month, after upgrading my hosts I had some really annoying issue’s, I couldn’t connect my iSCSI (QNAP) datastores and the hosts failed with a PSOD.. once I checked the HCL at the VMware website I saw that my HP DL360 G5 isn’t supported anymore.. time to rollback the latest installation.


Solution:

(Re)boot the host and press R to start the Recovery Mode..

Installed hypervisors:

HYPERVISOR1: 5.0.0-623860
HYPERVISOR2: 5.1.0-799733 (Default)

CURRENT DEFAULT HYPERVISOR WILL BE REPLACED PERMANENTLY
DO YOU REALLY WANT TO ROLL BACK?

 

Press Y to start the roll back

image

 

Result:

image

The host is downgraded and back online again with VMware vSphere ESXi 5.0.0

sanderdaems

Sander Daems is founder and author of this blog and working as a Sr. Infrastructure Consultant by IT-Value. Sander has over 10 years experience in IT, primary focus: virtualization, storage and SBC

More Posts - Website

Follow Me:
TwitterLinkedIn

VMware: VUM and MS SQL 2008 Standard support

July 25th, 2010 No comments

Duncan Epping wrote July 22nd:

I received multiple questions around this so decided to ask around internally. I managed to get ahold of the VMware Update Manager (aka VUM) Product Manager and after exchanging a couple of emails this is the outcome:

VMware vSphere Compatibility Matrixes

Table 13 on page 14 of the above linked document states that VUM doesn’t support MS SQL 2008 Standard. This is however untrue and should be considered as a document bug. It is supported and the document will be modified soon to reflect these changes.

 Oke, it’s a document bug, you can install it safely! 🙂

sanderdaems

Sander Daems is founder and author of this blog and working as a Sr. Infrastructure Consultant by IT-Value. Sander has over 10 years experience in IT, primary focus: virtualization, storage and SBC

More Posts - Website

Follow Me:
TwitterLinkedIn

Categories: VMware Tags: , , ,